If your command hub is not working any more due to a bad WiFi or network configuration change, you can reset it, though this is an advanced procedure so we'd only recommend it if you're confident with this sort of thing.

BE CAREFUL! This procedure will reset the Hub, but will also wipe Robotical's custom configuration and reset the Hubs to their manufacturer's default.

Make sure you are confident that you will then be able to re-do the setup and install for the Hub before clearing its configuration. Once you have done this, you won't be able to undo it! 

If you're still unsure, please contact us first!

First, you need to Factory Reset the hub

Press and hold the Reset button (next to the "Mode" switch) for 10 Seconds.

The front Power LED shlould blink slowly at first, then faster, and once 10 seconds have passed, faster still. When at the third speed, you can release the button.

The 2 WiFi status LEDS should switch off and then come back after a few seconds.


Set up the Hub

Your Hub will now be in its default state, so we need to configure it to change the network name and to get Scratch etc. on to it.

The SD card in the hub has all the files you'll need to do this.

Follow the instructions below to complete the install:

Through the same link above, you can download updated install files if you wish; However, the files your hub came with will let you reset it back to how it was when you received it.

As always, we're happy to help if you get stuck, just open up a new chat!

Did this answer your question?